GDevelop 3.6.83

GDevelop 3.6.83 is available!
It’s a hotfix that should fix crash with lights objects on Windows. :slight_smile:

Here are all the changes from version 3.6.81:

New (partial) Italian, Polish and Chinese translations! Your help is welcome, you can contribute on
New ‘Pick nearest object’ condition
New condition to check if a mouse button is released
New condition to check if a key is released
New sound system for HTML5 with huge performance improvements
Update rendering engine of HTML5 (Pixi.js) for improved performances
New “Advanced 3D tower” technical demo
Add Backspace as an alternative to Delete key shortcut in most editors
Fixed the high cpu usage when switching to the event editor on Linux
Fixed images insertion order when adding multiple picture to an animation
Fixed sprite global color action for HTML5 games
Fixed scale factor of Sprite objects being negative when object is flipped
Fixed pathfinding not working for native games
Updated titles of some editors to make them more consistent
Fixed crash with tilemap and large tilesets
Fixed some GTK3 glitches
Fixed wrong initial sprite size and animation when custom properties were set in HTML5 games

For now this version is only available for Windows, you can download it from the GitHub page:

If everything looks good, I’ll make this version publicly available from the website :slight_smile:
Version 3.6.82 is already available for Ubuntu and should be similar to this one as the fix is only for Windows. I’ll see if I can update it on Ubuntu so that version number will be the same for all platforms :slight_smile:

Lights works flawlessly now :smiley:

Awesome! Think that ok to release it publicly :slight_smile:


Love this dev software.

However, just upgraded to new version and now I can not get preview to work?



OS… Windows, Linux?
Did you try to reinstall?

What’s the error? Is it HTML5 or native game?

For HTML5 game, please clear the cache of your browser (Ctrl+F5 usually) :slight_smile:

Using Win7

Preview opens a tab in Chrome called localhost:* and stays black?

Tried clearing cache and F5.

also reinstalled old version - same result. So have re-installed this version hoping for a fix.

Ctrl + F5 for a hard refresh :slight_smile:

What is the error message? You can read it in the console, open it with Shift + Ctrl + J in Chrome.

Errors appear to be:

Failed to load resource: the server responded with a status of 404 (Not Found)


Uncaught Error: Resource with name “gem3v.png” already exists.

Apologies - I am a new to this. While trying to track this down I notice example files allow replay in the scene window. I can not seem to replicate this in my code. Have tried enabling the options for native and HTML5 in ‘Extensions’. I am clearly missing something.

Can you send us your project file with all the images in a zip (you’ll need to host it on a download website) ?

Native games → Preview in the editor
Web/HTML5 games → Preview in the web browser
If both platforms are activated, you can select one to preview by clicking on the arrow under “Preview”.

Roger that - will attempt to package up tomorrow night.

On the HTML vs Native - the coordinate system appears to be different. Putting one object around another gives different displacement of the placed object?

No, it’s the same coordinate system. Are you talking about the action “Put an object around another” ?

After update Preview is not working !!! just black screen , i try all browser !! i clear everything cache and history , the same problem!!! Any solution ???

We can’t help without clear indications.
Can we have your project file (with all the resources) ?

do i have to send all the projects !!! it will be hard :wink: i will use the old version back , thanks …

(Thanks for your help in making this software better… :neutral_face: )

You can make a easier thing : test if the examples works in HTML5.

What do you mean ??? try the exporting files ???

No, do the preview in GDevelop for some of the examples provided with it.

that works :cry: :cry: :cry: but may projects work normally on the old version , but the issue only on the new version !!!