How does the Top-down movement animator extension work?


From what it sounds like, it should automatically change the animation when you move a direction as long as it’s set up correctly.

It looks like you simply need to put an animation name like “Walk” for example and then name each animation “Walk0” “Walk1”, etc…

But nothing seems to happen when I do. So I’m wondering what I’m doing wrong here or if there’s something I need to add to the events maybe. There doesn’t seem to be a lot of options there.

Edit: Just tried the platformer character animator extension and that one seems to work how I expected. So I feel like the top-down one just isn’t working correctly.

Was not supposed your animation be named as 'Walk0" instead of just “Walk”?

If you mean under “Animation name”, I have it correct. It can be anything there and then you name your actual animations the same thing but with a 0, 1, 2, etc next to it.

I made a new project from scratch and now it seems to be working. So I guess there’s something wrong in the current project itself that I gotta figure out. Maybe it’s a version issue since I made that project with the beta version.
Anyhoo I guess this is solved for now.

Hi Vazz, I’ve used a similar animator extension for pathfinding. I just tried the TopDown animator and it worked for me.

Yeah it works for me now in new projects, I think my original project was just bugged which isn’t a big deal since I had just started.

I actually wanted an animator for pathfinding as well. Is the one you used the NavmeshPathfindingAnimator extension? Trying to figure it out now.

Yes, that’s the one. It works really well although I can’t get the inbuilt action to change the animation manually to work.

Ahh. I can’t get it to actually play the animation fully. It will change the animation to match the direction correctly but it’s stuck on one frame of the animation the whole time instead of playing the whole loop like the top-down and platform animators do. Oh well, guess I’ll just rely on doing things the long way.

That part works well for me.

Just checking, have you set the animation to loop in the object properties?

Hm, I guess it’s another me problem then.
I did set the animations on loop although even if I didn’t, it should at least play through the animation once. It also gives me a black screen on preview if I leave the “number of directions” option on 0 instead of 8 or 4.

Been running into too many bugs lately. I tried reinstalling gdevelop but maybe I need to wipe all traces of it off my computer first. :weary:

Yeah sorry, I realised my mistake about the loop and came here to say so, but saw you typing and waited. And I had the same black screen problem as you a month or so ago and realised the number of directions couldn’t be left at 0. When I first saw your post I tested it in the Top down animator and leaving it on 0 did work.

I tried your example and the movement/animation worked fine. So I made another new test project from scratch and did the same exact thing and it still wouldn’t work in my project. I was pulling my hair out trying to figure it out and I finally did.
The problem with my project is I didn’t put an obstacle. Once I did, it started working. So there we go, for anyone trying the navmesh animator, make sure to put an obstacle somewhere for it to work. :sweat:

And I have the same problem as you where the extension’s change animation doesn’t work. The normal change animation works but it bugs out if you click on or next to the obstacle.