[SOLVED] (kinda) How to turn off animations in GDevelop interface?

Hi all, firstly I apologize if this has been answered already.

Is there a way to disable animations of the GDevelop editor?
The “Variable” text moving upwards when clicking it in an event/condition, the grey line turning into a purple line from the center, the fill-in circle effect when clicking the Preview button, the Project Manager sliding in from the left. etc.
I understand animations are a great visual feedback when something is pressed, but animations are very tiring to watch for me (sensory issue?). I also have a “potato” laptop, so I often have to watch the animation(s) play out before able to do anything else.

I looked in preferences briefly but couldn’t really find anything.
Thank you for your help!


I think it doesn’t exist yet, so you should definetely add this in the Feature Request forum. It will be very interesting for GDevelop team.

1 Like

Have you tried setting your system settings to preferring reduced motion? Browsers should automatically reduce some of those animations & tell websites (including web apps like GDevelop) about your preference if you do.

According to MDN, here are the settings that browsers look for:


1 Like

Hi Arthuro, I use Windows 10 and have turned off animations for a while now, although I turned it off through the left window’s checkboxes. Going to that settings shows it was turned off already.

I should note that this is a modified Windows 10 called Atlas, but I do have a normal install of Windows 10 and will tell if results differ on that. (spoilers: Project Manager still slides into view, but atleast the parameter editor doesn’t animate anymore. It’s a step forward)

@infokubarcade thanks for the suggestion! If trying it on regular Windows 10 doesn’t work I’ll try to do that.

As arthuro has provided a semi-working answer, I’ll just mark the topic as [SOLVED].
Yes, the problem is still there, so I made a Feature Request topic:

1 Like