[Solved] New video loader and export problem


at first I want to thank Bouh for this extension! :pray:

I used it and seems to work, but:

I make video object and put in on scene. Then in events I made command to play video on the beginnig of the scene. It does, but the are problems:

-view seems to be duplicated - one overscaled video on back and one smaller on front

-sometimes in preview I can see this bigger one and sound is in normal tempo, but animation is much faster

-sometimes in preview I can see both - bigger and smaller, and smaller one in front is ok (music and animation) but I can see the bigger one in the background with faster animation

-and most important: when I export game (windows zip) an application after loading is just gray screen and nothin happen… earlier I hadn’t problem with export so maybe it’s beacause of video loader extension?

Maybe I do something wrong? Any help, please :slight_smile:

UP :pray::pensive:

I figure out how to solve problem with double video, but still can’t export workning game.
Still after loading is grey screen.
Please, anybody has idea how to fix it?

How you process for the export ?
Video playing in preview ?
In ressources tab your path file for the video are correct ?
When you open the developper tools (CTRL+SHIFT+I), you have a error ?

Hey Bouh,
thank you for the answer :slight_smile:

I export as windows zip file.
Yes, in preview everything is fine.
Video had good localization. I tried to remove video but the problem with export remains.
Oh, there’s an error in fact - honestly I’m not sure which file is missing.
In this path I have saved only project and other stuff are in different localization.
What to do :hushed:

-You should open this developper tools in your game exported.
And open it bigger please i can’t see.

  • If you can send me the project in PM. I will take a look.
  • You load a custom font with a url ?
  • Maybe your videos codec are not right.

This is how my exported game looks like after loading:

And ctrl+shift+i doesn’t work - I cant open developper tools in this game window.
But here’s bigger view from GD preview (there’s a lot of errors - it’s weird cause I don’t remember I was using any “bunny” or “napis”):

I can’t send you project by priv cause it authorize only images :no_mouth:
Thank you for helping me - I would never figure it out by myself :relaxed:

P.S. I didn’t use custom font, and my video has right codec (H.264 and ACC)

Eventually is it possible to copy objects and events from one project to another? If so, I can always make a new project, but making everything from the beginnig (if copy wouldn’t be possible) would kill me :stuck_out_tongue:

  • Don’t worries about Bunny it’s normal, this don’t bug your game.
  • “napis” look like a animation sprite you’ve imported by yourself. Many file exist napis0001.jpg to napis0026.jpg, look your animation sprites.
    “Napis” seem does mean “title” or someting like this in Polish.
  • Your game exported is grey :o , can you Zip your project and upload it on https://send.firefox.com/, and give me the link :slight_smile:

ok, now I remember taht one animation has name “napis” but why it can’t find it… I didn’t change it’s location and it works on preview. hmm, anyway - reload should help?

By the way I just made new project and put just few simple elements with wideo loder too, it works on preview but I opened developper tool and there are errors too - don’t know why - i just made it :no_mouth:

Ok, do you need only project file, or all resources too? cause I have it in different location than project :slight_smile:

I just exported this new project and everything is fine! I’ll try to reload those files “napis” - maybe this will help. Unfortunatelly to test it I must wait till tomorrow cause I used my 2 exports a day :slight_smile:
So send you this project anyway or rather wait till I test it? Cause I don’t want to bother you too much :blush: Maybe this is a good idea - if it still wrong tomorrow I’ll send you project. Just tell me if the json file it’s enough :slight_smile:

Try and we will see later, is you have again the issue send the both folder :wink:

Ok, and thank you! :pray::relaxed:

Hey, I fixed most of errors. This is what remains:

And unfortunatelly after export game still is just gray screen… :sweat:

Here’s link to my files - I put zipped folder with assets to the project folder.


I hope you will be able to find out what is going on - and I’m very grateful for helping me :relaxed:

P.S. In assets folder in “proba7” is last export if you want to take a look :slight_smile:

1 Like

This error about debugger is not a problem, like bunny.png don’t worries.

Currently you use a folder external to the project for your image and video resources, I advise you to put everything with the project file. Because all the links are dead when you share a project like that.

GD might not find all the files, I also saw that you use Cyrillic letters?
Prefer to use simple letters, because on my computer.
“dla obłąkanych” is recognized as “dla obêÑkanych”
If i have this problem, GD can have this problem too.
Then when you export the game the path is broken, the files are not packaged and your game is almost empty.

1 Like

@4ian I see this problem comes up very often for people new to GD. They store the resources outside the project folder, it might work in preview but when they export or upload to the build service it is no longer works because resources are missing. This is why I did prefer to have the resources editor back. It might be few extra steps to add resources but could avoid this kind of problems or when we select resources GD should copy the resources in to the project folder straight away and use that instead of the ones outside. But then people get confused where to change, edit the resource. Forcing people to use the project folder through the resource editor would be the best way to do it.


Thank you Bouh - I will try to put all my files in project folder. Is there a fast way to relocate resources or I have to change all images inside sprite editor?
In fact I have polish letters (not cyrillic) only in the title of main folder, but I was hoping it’s fine, cause earlier I have exported game many times and it worked. But now I’ll change it too :slight_smile:
I hope this will help :upside_down_face:

ddabrahim - I think your’e absolutely right - it would much easier and safer :slight_smile:

Thanks guys, I’ll move my resources and let you know if it helped :slight_smile:

…I’m gonna cry :sweat:

I relocated all files and made sure to have in resources only that files what were needed and been located in project folder. No additional errors in developper tools, in preview everything is just fine. I also checked properties if it’s ok and to avoid polish letters. And the problem remains…
I have no more ideas what’s wrong.
And I exported today on two ways - one as windows zip, and another as auto-installer. Both with same effect of empty game.
Whyyyy… :disappointed_relieved:

I zipped this regenerate project again if you would like to take a look:

Will be grateful for any help, as always :smirk:

I don’t know what the problem is the error messages in the console are not very helpful. I just leave my experience here for @4ian

Preview does work but after exporting it doesn’t work either in Firefox and Chrome using a web server.
In Firefox I was getting a parsing error for mp3 and wav files. So it might got something to do with the audio parser. The audio files are there, being exported with the game, path is correct but parsing failed.
After removing all the audio from the project and the event to play any music or sound, this is the only error message I get in Firefox:

Source map error: TypeError: NetworkError when attempting to fetch resource.
Source map error: request failed with status 404
Resource URL:
Source Map URL: pixi.min.js.map

And this is the explanation for the error on the mozilla website:

In Google Chrome with a web server this is the only error message I get, 2 images not found:

Failed to load resource: the server responded with a status of 404 (Not Found)
Failed to load resource: the server responded with a status of 404 (Not Found)

I have no idea what this is, probably not something we can fix on our end.

omg, it sounds bad :frowning:
thanks anyway!
do you think the best I can do is just make new project and build whole game all over again?