Undo crashes the Piskel editor

When pressing the keyboard shortcut ctrl+Z (cancel the action) the screen becomes black. I spent an hour drawing and accidentally * forgot about this bug - I pressed this combination. And all the work is in the trash.

the error occurs not only for me alone. I am teaching one guy and he also wrote that the entire editor disappears when he presses the ctrl +Z key combination.

Hello, vinurd
That’s a sad thing…

What I did was stop using Piskel integrate to Gdevelop for my own games and just use it for examples and quick tests, because like you sometimes I forgot about the bugs…

Another reason to stop using the built-in Piskel is the difficulty of overwriting the image when trying to save it. I made a thread about it: Piskel does not overwrite the image when expected and sometimes crushes while using Ctrl + Z (undo)

If you really like Piskel you can download it from the website or use it online, as these problems only occur in the integrated version.

I just tried ctrl+z in the GDevelop Piskel, and it worked, so we need more precise steps to reproduce the issue.
Are you up-to-date?

Yeah, it works. But if you use it a few times in a row usually crashes the Piskel (and maybe the Gdevelop or PC).

I did 20 brush strokes, 20 undo, 20 redo, 20 undo, no crash.
I did not find this bug reported on the GitHub.
Again, precise steps, please.

draw more animation frames, everything is as usual, I had 10 empty frames, drew a character, decorated it and then pressed ctrl+Z

1 Like

In another topic Speedstar90 have the same issue and Bubble confirmed too just using ctrl+z a few times: Piskel Editor Bug

Maybe weaker computers crash more easily… I don’t know

I have i Core 9 and GTX 3070 gaming PRO and 32GB
I can’t say that because of the weakness of the hardware I saw a black screen

I was able to reproduce it with 9+ frames, I have forwarded the issue.