When you test your game and it stops at 95% load - SOLVED

That moment when you test your game and it stops at 95% loading :cry: :cry: :cry: :cry: :cry: :cry:

I’ve been over and over my code and can not find the problem. Short of deleting everything one by one, is there a quicker way to find the problem?

Hi, open the dev console of your web browser and load the game (press F5 to reload it). Errors messages should appear in the console. The bug is probable caused by a invalidité/missing picture.

Ah, okay, soo looking at this gibberish I am guessing it has a problem with one of my images used in a sprite? One of the last things I did was to change the animation of a sprite using an image of different dimensions. Could that be the cause?

It can be but it should not crash. Can you send us the game here or by PM so we can make à look ?

Sure, hold one

PM sent

The latest changes were lines 60-62 if that helps. Was testing out a “sinking lillypad for wrong choice” kind of action.

I’m not able to reproduce the bug on my computer. :frowning:

Browser cache?
What if you open an incognito window and try?

It opens to the first scene for you?


Try to clear the cache of your webbrowser or force a full reloading of the page (Ctrl+F5 or Shift+F5 or Alt+F5 depending on the webbrowser).

Cleared cache, tried an incognito window and internet explorer window. All stops at 96% :cry:

Then, can you send me the exported game ?

Tried to use the zipped copy I sent you but it stops at 91%
Ctrl+F5 reloaded the page but still stopped loading at 91%

Sigh. I don’t want to start from scratch again :cry:

Yup, ill add it to that page link I sent you. Gimmie a minute

Here is the link. Stopping at 91% on mine


By looking into the “Network” tab of the dev tools of Firefox, it seems that many pictures are not on the website (many 404 errors when the game tries to load them).

Oh. They are all there. I wonder why it is not recognizing them? :confused: Strange

It also seems that you added multiple time the same pictures in the image bank (I can see XXX.png and XXX.png2 in the pictures list in the network tab).

Was that the squashed lillypad? I remade a second one with the canvas dimensions of the other lillypads to see if that was the problem. Didn’t help though.