[SOLVED] Dialogue Tree refuses to proceed to next branch after option chosen

How do I…

How do I fix the dialogue system not proceeding to next branch after chosen option.

What is the expected result

The game is supposed to proceed to the next line of dialogue after an option has been chosen.

What is the actual result

The game remains in the options state.

Related screenshots


Dialogue Tree:

End of ‘Start’ (main) branch script:

Options Menu:

Result of clicking any option (i chose the 2nd one):

It didn’t proceed

Project files (optional)

Not sure if I can provide one, even if i recreate it will probably end up working.

I’ve been stuck on this for weeks on end.
I’ve read the events over & over again, I can’t tell if the problem is Yarn or me (most probably me tho).

1 Like

Hi. For your button press events, instead of just ‘Confirm selected option’ put the action ‘Select option at index 0’ before that, and see if the button works. Obviously, each button event will need the index number changing, 0, 1 and 2, if you have three options, or just 0 and 1 for two. ‘Select option’ action must go before ‘Confirm’ action.


I think the issue is that the game doesn’t know that clicking choiceBtn1 represents choosing option 0. The button has option 0 text in it, but that’s not going to result in the game knowing that pressing that button means you want to choose option 0. All the game knows is that there is a text object with some text in it that was grabbed from Yarn. By adding the action I suggested, we might solve this.


Hsy, thx 4 responding ^ ^
i’ll check it if that fixes the issue tmrw afternoon :+1:

1 Like

i just tried applying the change to all 3 buttons but still refuses to proceed, the game is still in the ‘options’ state.

That’s disappointing :frowning: I found these two posts that may offer some clues to help. The first one (who seems to have been successful) is where I got the idea I gave you yesterday.

I don’t think I can help further because I’ve only ever used the list type of options in Yarn. I do plan on mocking up a system with buttons so I can do a tutorial, but I don’t know when I’ll get round to that. Sorry the idea I had didn’t work. Maybe someone else can help.

thx for the assistance :+1:
i’ll look through the forum posts and see if they can solve my issue.

I seem to have found a way to get it to work, though it is a little odd and I have no idea why it doesn’t do what I originally suggested. But it’s nice and easy. You need a sub-event for the button press events, with ‘Selected option has changed’ as the condition, and ‘Confirm selected option’ as the action. Please let me know if this works for you.


1 Like

alright thx! :+1:
I’ll check it out after school when I arrive home.

I have just tested your solution to my issue and it works!
Thank you so much, it means alot to me that someone was able to help me fix the issue i’ve been dealing with for weeks on end :slight_smile:

1 Like

Yay! I’m so pleased. It was bugging me over the weekend and I am stubborn! I think I’ll do a tutorial about this because it’s something that’s come up before. Anyway, good luck with your game. Please put ‘[Solved]’ at the beginning of your original post title. Thank you.

1 Like

Alright thx :+1:
Good luck with the tutorial!
Just updated the title.