Liluo link and apk problem

hi again. liluo link is not generating and showing this error:

please help me what is reason? also on the android, my game says: Application Error
The connection to the server was unsuccessful.
(https://localhost/index.html )

it happens after gdevelop latest update. how to fix this? reinstalling not fixes problem.

Error 504 is a gateway timeout error.
If your error has not fixed itself by now, you may have some issue in your (local) network configuration.
Regarding the URL you shared, this is a local link that will only work on your own computer. Even an Android device on the same local network won’t be able to open that link.

okay but when i install my game on android it says on some phones

: Application Error
The connection to the server was unsuccessful.
(https://localhost/index.html )


  • Are these old phones?
  • It gives this message during the install, or when you try to run the game?
  • Just to make sure: have you used this localhost URL somewhere in the game?

it gives this message when i try to run game.
not on the old phone but on the some androids.
no i don’t have used any url in my game, so i don’t understand what is it and how to fix it

Can you confirm the Android version number of the phones you try to run your game on?
I think the minimum is 7 or 8, but it might depend on the type of game.

Also, try to build one of the example games and see if your phone likes it any better.

No, it’s android 11. Can you explain what is it? It worked then but now it says this error :frowning:

Have you tried an example project? Have you tried another phone?
We need to know if the issue is specific to your project, or your phone.
I’ve never seen this error before. :person_shrugging:

Hi, we also report it

Still happening to me

1 Like

:wave: Thanks for joining us.
In your linked post, you wrote: Happens to me about half the time I try to open the app too.
Can you elaborate? app is your game or GDevelop? What happens the other half of the time?

Yes, sorry if I didn’t give all the information there hehe. I think there is another post that also talks about this. When I export as APK to android, when installing and then opening the game on mobile, about half of the time I get this error and the game doesn’t launch. I have to force stop and go back in and try until I get into the game. The times I have this error the cordoba logo does not disappear and it does not load, then that error appears. The remaining times, the APK loads and then enters the game (the game works properly the times I haven’t this error).

Do you remember if the issue started with version 146 of GDevelop?
Could you try to reproduce the issue with one of our example projects?
And please confirm the phone model and its version of Android.

yes and it works on some phones.

I’m not sure which version because I haven’t exported the APK to android for many months until recently. I didn’t have this problem before. I tried to export an example and it works every time I open the APK from my cell phone, so it is not supposed to be a problem with the cell phone or android version. I test it from a Moto g31 with android 11. When I open the developer tools I get these errors, but I don’t think they really affect.
DevTools failed to load source map: Could not parse content for file:///C:/Users/Usuario/AppData/Local/Programs/GDevelop/resources/app.asar/www/ Unexpected end of JSON input
DevTools failed to load source map: Could not parse content for file:///C:/Users/Usuario/AppData/Local/Programs/GDevelop/resources/app.asar/www/ Unexpected end of JSON input

Thanks for the useful information.
It would seem the issue is with the tilemap feature. Usually, messages in yellow are not important, and red ones matter, but I’m not sure how this rule applies to the tilemap feature.
If you are indeed using the tilemap feature in your game, try exporting one of the tilemap example projects, see if you get the same issue.

I don’t use tilemap in my project. Anyway, I exported one of the examples that included tilemap as an APK for Android but it worked fine every time I opened it on mobile. There is one more warning that appears in the developer tools.

There is no other message or warning than these two.

Thanks for trying the tilemap example.
I don’t think that error is relevant. I see it in mine as well, now that I looked for it.
You’re using the dev tools in the main GDevelop window? If so, do you get any interesting errors from the preview window itself, when previewing your own project?

Also, did you get a chance to try your own project in other phones?

I don’t see any other error or warning messages in the developer tools console when I open the game from the Gdevelop window and preview, not even when opening developer tools in the preview window itself.

1 Like

Sorry for not answering this line. I was testing on a higher power cell phone and the same thing happens to me that sometimes the screen with the Cordoba logo is not redirected to the loading screen and other times it comes out and goes to the screen with the loading bar. The difference is that even if you don’t go to the screen with the loading bar, when you reach the same loading time, you enter the game. Therefore, the game always works in the case of a phone with higher RAM and better processor, even if there is no redirection to the loading screen.

Good to know, thanks!
So, if the issue doesn’t occur with the example project you tried, we’ll assume it is specific to your project.

Before proceeding, make a backup of your project. Right-click on the folder and zip it, for instance, or copy-paste the whole folder.
Now, if you can share your project folder, it will be easier for us to investigate. Otherwise, let’s proceed:
First, you should check some tabs in the first Game settings menu:
Properties - Avoid leaving fields blank
Icons - Add all icons/thumbnails
Resources - No line is yellow/orange/red

Second, if you use extensions, please list them.

Third, after making sure you have a backup of your project, delete all the scenes and external layouts/events except the first scene, make sure the project is still functional and try exporting again. If that fails, restore a backup, delete the first scene, make sure the project is still functional and export again.